NewPipe

Lightweight YouTube frontend GPL-3.0-or-later

NewPipe Legacy

Lightweight YouTube frontend for OS versions 4.x GPL-3.0-or-later